ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021421ClearOSapp-web-proxy - Web Proxypublic2018-09-07 14:502018-11-05 08:26
ReporterNickH 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version7.5.0 
Target VersionFixed in Version 
Summary0021421: Proxy fails to start if an ACL entry is a subdomain of another entry
DescriptionIf you whitelist a subdomain of a domain that is already whitelisted, the proxy will fail to start. It should be easy to validate a new entry, either deleting the existing entry if it is a subdomain of the new entry with a warning, or refusing to accept the subdomain being entered.

Please see ticket 563734 where this happened. The error given was:

Aug 26 14:41:44 gateway systemd: Starting Squid caching proxy...
Aug 26 14:41:44 gateway squid: 2018/08/26 14:41:44| ERROR: '.nvr01.corp.westonemanor.com' is a subdomain of '.westonemanor.com'
Aug 26 14:41:44 gateway squid: 2018/08/26 14:41:44| ERROR: You need to remove '.nvr01.corp.westonemanor.com' from the ACL named 'whitelist_destination_domains'
Aug 26 14:41:44 gateway squid: Bungled /etc/squid/squid_whitelists.conf line 15: acl whitelist_destination_domains dstdomain .westonemanor.com
Aug 26 14:41:44 gateway squid: FATAL: Bungled /etc/squid/squid_whitelists.conf line 15: acl whitelist_destination_domains dstdomain .westonemanor.com
Aug 26 14:41:44 gateway squid: Squid Cache (Version 3.5.20): Terminated abnormally.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0017721confirmed Whitelist overlap causes bungled file. 
has duplicate 0019741closedpbaldwin Duplicate Entries or Overlapping Entries bungle whitelist 

-  Notes
(0007941)
pbaldwin (administrator)
2018-09-07 18:06

It's too bad that this type of issue is considered a fatal error. I'm sure there's a good reason... I think.
(0007961)
NickH (developer)
2018-09-10 05:39

It looks like https://tracker.clearos.com/view.php?id=19741 [^] is a duplicate of this.
(0008451)
NickH (developer)
2018-11-05 01:17

Also duplicate of https://tracker.clearos.com/view.php?id=17721 [^]

- Issue History
Date Modified Username Field Change
2018-09-07 14:50 NickH New Issue
2018-09-07 17:50 pbaldwin Status new => confirmed
2018-09-07 18:06 pbaldwin Note Added: 0007941
2018-09-07 18:06 pbaldwin Product Version 7.6.0 => 7.5.0
2018-09-10 05:39 NickH Note Added: 0007961
2018-09-10 05:42 pbaldwin Relationship added has duplicate 0019741
2018-11-05 01:17 NickH Note Added: 0008451
2018-11-05 08:26 pbaldwin Relationship added duplicate of 0017721
2018-11-05 08:26 pbaldwin Status confirmed => resolved
2018-11-05 08:26 pbaldwin Resolution open => duplicate
2018-11-05 08:26 pbaldwin Assigned To => pbaldwin
2018-11-05 08:26 pbaldwin Status resolved => closed
2018-11-05 08:26 pbaldwin Assigned To pbaldwin =>