ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001953ClearOSapp-network - Network Settingspublic2014-09-10 10:032018-10-09 10:03
Reporterdloper 
Assigned Topbaldwin 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version7.5.0 UpdatesFixed in Version7.5.0 Updates 
Summary0001953: Adding VLAN interface to network configuration does not add interface to role in network.conf
DescriptionWhen adding a VLAN interface in IP Settings, the network interface is not added to /etc/clearos/network.conf. This means that it does not get the proper role.

Workaround: Manually add the VLAN interface to /etc/clearos/network.conf in this format (where eth1:2 is the VLAN interface and eth1 is the existing interface):

LANIF="eth1 eth1:2"

Afterwards, restart the firewall:

service firewall restart
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001295)
pbaldwin (administrator)
2014-09-10 17:24

Unable to duplicate. Was there any "trace" in the /var/log/system log file? In the source code, I can see that the interface role is set soon after the interface is configured. If something blows a tire in between, then the role won't be set.
(0008121)
pbaldwin (administrator)
2018-10-09 10:02

This seems to be okay in ClearOS 7.5. Please re-open if able to duplicate.

- Issue History
Date Modified Username Field Change
2014-09-10 10:03 dloper New Issue
2014-09-10 17:16 pbaldwin Status new => acknowledged
2014-09-10 17:24 pbaldwin Note Added: 0001295
2018-10-03 07:43 pbaldwin Target Version => 7.5.0 Updates
2018-10-09 10:02 pbaldwin Note Added: 0008121
2018-10-09 10:02 pbaldwin Status acknowledged => resolved
2018-10-09 10:02 pbaldwin Fixed in Version => 7.5.0 Updates
2018-10-09 10:02 pbaldwin Resolution open => fixed
2018-10-09 10:02 pbaldwin Assigned To => pbaldwin
2018-10-09 10:03 pbaldwin Status resolved => closed