ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007501ClearOSapp-network - Network Settingspublic2016-02-28 12:332017-04-06 08:16
Reportermarclaporte 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusconfirmedResolutionopen 
PlatformOSOS Version
Product Version6.7.0 
Target Version6.9.0 UpdatesFixed in Version 
Summary0007501: On Linode, can't connect to server after a fresh install and completing of the wizard
DescriptionWe contact Linode support about suspicious items in logs, but they responded they don't support StackScripts.

Please see attached screenshot

Steps To ReproduceTo reproduce:

1- Fresh install of ClearOS 7.x via StackScripts:
https://www.linode.com/stackscripts/view/13940 [^]

2- Complete the initial ClearOS GUI wizard

3- Reboot

And then, we are unable to connect to the server.
TagsNo tags attached.
Attached Filespng file icon 2016-02-28-linode-cant-connect-after-reboot.png [^] (169,864 bytes) 2016-02-28 12:33


png file icon 2016-03-01-ClearOS-StaticIP-Linode-Workaround.png [^] (153,211 bytes) 2016-03-01 14:32


png file icon 2016-04-29-linode-stackscript-clearOS-6x-network-issue.png [^] (32,631 bytes) 2016-04-29 22:24

- Relationships

-  Notes
(0002721)
marclaporte (manager)
2016-02-28 15:46
edited on: 2016-02-28 15:47

It's still possible to connect to the machine via https://www.linode.com/docs/networking/using-the-linode-shell-lish [^]

[root@ ~]# ping google.com
ping: unknown host google.com
[root@ ~]# ifup eth0
                                                                                                                     
Determining IP information for eth0...dhclient(3678) is already running - exiting.
                                                                                                                     
This version of ISC DHCP is based on the release available
on ftp.isc.org. Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.
                                                                                                                     
Please report for this software via the CentOS Bugs Database:
    http://bugs.centos.org/ [^]
                                                                                                                     
exiting.
 failed.
[root@ ~]# /etc/init.d/network restart
Restarting network (via systemctl): 8021q: adding VLAN 0 to HW filter on device eth0
[ OK ]
[root@ ~]# ping google.com
ping: unknown host google.com

(0002741)
dlucio (reporter)
2016-02-29 15:48

I did a dhcp tcp capture:

50.116.18.11.bootps > 45.33.125.185.bootpc: BOOTP/DHCP, Reply, length 320, xid 0xf53613d, Flags none
Your-IP 45.33.125.185
Client-Ethernet-Address f2:3c:91:f1:25:70
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: ACK
Server-ID Option 54, length 4: 50.116.18.11
Lease-Time Option 51, length 4: 86400
Subnet-Mask Option 1, length 4: 255.255.255.0
BR Option 28, length 4: 45.33.125.255
Domain-Name Option 15, length 18: "members.linode.com"
Domain-Name-Server Option 6, length 12: 72.14.191.5,72.14.179.5,72.14.188.5
Hostname Option 12, length 10: "li1062-185"
Default-Gateway Option 3, length 4: 45.33.125.1

If you read, the DHCP sends the default gw. This makes me thing. This makes me think it has to be with the vLAN? or maybe a DHCPd bug.
(0002751)
marclaporte (manager)
2016-03-01 14:33

I added a workaround in the image I just attached
(0003151)
marclaporte (manager)
2016-04-29 22:27

On 2016-04-30, I attempted to install ClearOS 6.x on Linode via the StackScript: https://www.linode.com/stackscripts/view/7560 [^]

Error and workaround can be seen at:
2016-04-29-linode-stackscript-clearOS-6x-network-issue.png
(0003871)
marclaporte (manager)
2016-09-08 12:27

Should be retested give https://tracker.clearos.com/view.php?id=2263 [^] has been resolved
(0003931)
pbaldwin (administrator)
2016-09-15 08:30

The most recent StackScript for ClearOS 7 does not exhibit this issue. Setting version to ClearOS 6.

- Issue History
Date Modified Username Field Change
2016-02-28 12:33 marclaporte New Issue
2016-02-28 12:33 marclaporte File Added: 2016-02-28-linode-cant-connect-after-reboot.png
2016-02-28 15:46 marclaporte Note Added: 0002721
2016-02-28 15:47 marclaporte Note Edited: 0002721 View Revisions
2016-02-29 15:48 dlucio Note Added: 0002741
2016-03-01 14:32 marclaporte File Added: 2016-03-01-ClearOS-StaticIP-Linode-Workaround.png
2016-03-01 14:33 marclaporte Note Added: 0002751
2016-03-03 11:52 pbaldwin Status new => confirmed
2016-04-29 22:24 marclaporte File Added: 2016-04-29-linode-stackscript-clearOS-6x-network-issue.png
2016-04-29 22:27 marclaporte Note Added: 0003151
2016-05-02 11:13 pbaldwin Product Version 7.1.0 Updates => 7.2.0
2016-05-02 11:13 pbaldwin Target Version => 7.2.0 Updates
2016-08-30 09:54 pbaldwin Target Version 7.2.0 Updates => 7.3.0 Beta 1
2016-09-08 12:27 marclaporte Note Added: 0003871
2016-09-15 08:30 pbaldwin Note Added: 0003931
2016-09-15 08:30 pbaldwin Product Version 7.2.0 => 6.7.0
2016-09-15 08:30 pbaldwin Target Version 7.3.0 Beta 1 => 6.8.0 Updates
2017-03-21 08:43 pbaldwin Target Version 6.8.0 Updates => 6.9.0
2017-04-06 08:16 pbaldwin Target Version 6.9.0 => 6.9.0 Updates