ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006871ClearOSanaconda - Installerpublic2016-01-05 12:002016-12-16 14:04
Reporterpbaldwin 
Assigned Toabylund 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.1.0 
Target Version7.3.0 Beta 1Fixed in Version7.3.0 Beta 1 
Summary0006871: Anaconda issues with UEFI
DescriptionClearOS 7.1 fails to install if using UEFI. A standard Centos 7.1 installation works correctly.

Installation begins, the packages are installed and then it fails with the error message:
bootloader.write failed: failed to write boot loader configuration

Here is an extract from the program.log file contained in the dump package.

15:07:49,872 INFO program: Running... grub2-mkconfig -o /boot/efi/EFI/clearos/grub.cfg
15:07:50,359 INFO program: /sbin/grub2-mkconfig: line 241: /boot/efi/EFI/clearos/grub.cfg.new: No such file or directory
15:07:50,359 DEBUG program: Return code: 1

and from the anaconda.log:
15:07:49,703 INFO anaconda: bootloader.py: used boot args: rd.lvm.lv=clearos/swap crashkernel=auto rd.lvm.lv=clearos/root rhgb quiet
15:07:50,359 ERR anaconda: bootloader.write failed: failed to write boot loader configuration

The problem is that the directory "clearos" does not exist, but "centos" does - so you've missed something when renaming centos to clearos.

If I switch to a different shell when the error appears execute the following commands:
chroot /mnt/sysimage
grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg

then reboot, the system boots successfully. Otherwise it fails with a missing bootloader error.

Using BIOS instead of UEFI works correctly.
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0007641closedpbaldwin EFI boot mis-manages centos to clearos names for directories 

-  Notes
(0002481)
pbaldwin (administrator)
2016-01-05 12:01

This patch is likely involved:

https://github.com/clearos/anaconda/blob/clear7/SOURCES/anaconda-clearos-efidir-clearos.patch [^]

Along with the "shim" RPM -- file manifest:
/boot/efi/EFI/BOOT/BOOTX64.EFI
/boot/efi/EFI/BOOT/fallback.efi
/boot/efi/EFI/centos/BOOT.CSV
/boot/efi/EFI/centos/MokManager.efi
/boot/efi/EFI/centos/shim-redhat.efi
/boot/efi/EFI/centos/shim.efi
(0002491)
dloper (administrator)
2016-01-05 14:33

This packages need to have the directory changed:

shim
grub2-efi

Once these are changed, the system should pull the correct directory and then build the grub files appropriately.

#rpm2cpio shim-0.7-5.2.el7.centos.2.x86_64.rpm | cpio -idmv
./boot/efi/EFI/BOOT/BOOTX64.EFI
./boot/efi/EFI/BOOT/fallback.efi
./boot/efi/EFI/centos/BOOT.CSV
./boot/efi/EFI/centos/MokManager.efi
./boot/efi/EFI/centos/shim-redhat.efi
./boot/efi/EFI/centos/shim.efi


# rpm2cpio grub2-efi-2.02-0.17.0.1.el7.centos.4.x86_64.rpm | cpio -idmv
./boot/efi/EFI/centos
./boot/efi/EFI/centos/fonts
./boot/efi/EFI/centos/fonts/unicode.pf2
./boot/efi/EFI/centos/gcdx64.efi
./boot/efi/EFI/centos/grubx64.efi
./boot/grub2/grubenv
./etc/grub2-efi.cfg
./usr/share/doc/grub2-efi-2.02
./usr/share/doc/grub2-efi-2.02/COPYING
(0002511)
pbaldwin (administrator)
2016-01-07 09:31

Target version is 7.3 (or 7.2.1) since we don't have the build system workflow capabilities at the moment.

- Issue History
Date Modified Username Field Change
2016-01-05 12:00 pbaldwin New Issue
2016-01-05 12:01 pbaldwin Note Added: 0002481
2016-01-05 12:01 pbaldwin Status new => confirmed
2016-01-05 14:33 dloper Note Added: 0002491
2016-01-07 09:31 pbaldwin Note Added: 0002511
2016-03-09 14:04 pbaldwin Relationship added has duplicate 0007641
2016-11-16 09:12 pbaldwin Target Version 7.3.0 Beta 1 => 7.3.0 Beta 1
2016-12-09 21:02 pbaldwin Status confirmed => resolved
2016-12-09 21:02 pbaldwin Fixed in Version => 7.3.0 Beta 1
2016-12-09 21:02 pbaldwin Resolution open => fixed
2016-12-09 21:02 pbaldwin Assigned To => abylund
2016-12-16 14:04 pbaldwin Status resolved => closed