ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0021021ClearCenterapp-antimalware-updates - Antimalware Updatespublic2018-08-06 01:422018-08-14 12:41
ReporterNickH 
Assigned Topbaldwin 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.5.0 Updates 
Target Version7.5.0 UpdatesFixed in Version7.5.0 Updates 
Summary0021021: Anti-malware and Antispam updates working incorrectly
DescriptionPartly in reference to https://tracker.clearos.com/view.php?id=20961, [^] I can see a nightly yum update updates clearsdn-antimalware and clearsdn-antispam correctly then an hour after the jobs app-antispam-updates and app-antimalware-updates run and say they require updates. This is incorrect as they have just updated. You then get a php failure in app-base. Full logs including the yum update are below:

Aug 6 05:18:57 server software-updates: log: ------------------- software update ------------------------------
Aug 6 05:18:57 server software-updates: log: software updates installing...
Aug 6 05:18:57 server software-updates: log: Loaded plugins: clearcenter-marketplace, fastestmirror
Aug 6 05:18:57 server software-updates: log: ClearCenter Marketplace: fetching repositories...
Aug 6 05:18:57 server software-updates: log: Loading mirror speeds from cached hostfile
Aug 6 05:18:57 server software-updates: log: * clearos: www.mirrorservice.org
Aug 6 05:18:57 server software-updates: log: * clearos-centos-extras: download1.clearsdn.com
Aug 6 05:18:57 server software-updates: log: * clearos-centos-sclo-rh: download1.clearsdn.com
Aug 6 05:18:57 server software-updates: log: * clearos-centos-verified: mirror1-frankfurt.clearos.com
Aug 6 05:18:57 server software-updates: log: * clearos-contribs: www.mirrorservice.org
Aug 6 05:18:57 server software-updates: log: * clearos-epel-verified: mirror1-frankfurt.clearos.com
Aug 6 05:18:57 server software-updates: log: * clearos-fast-updates: download1.clearsdn.com
Aug 6 05:18:57 server software-updates: log: * clearos-infra: www.mirrorservice.org
Aug 6 05:18:57 server software-updates: log: * clearos-verified: mirror1-frankfurt.clearos.com
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-ad: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-antimalware: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-antispam: download3.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-business: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-content-filter: download3.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-dnsthingy: download3.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-dyndns: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-dynvpn: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-ids: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-master-slave: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-rbs: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-security-audit: download1.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: * private-clearcenter-verified-updates: download3.clearsdn.com:80
Aug 6 05:18:57 server software-updates: log: Resolving Dependencies
Aug 6 05:18:57 server software-updates: log: --> Running transaction check
Aug 6 05:18:57 server software-updates: log: ---> Package clearsdn-antimalware.noarch 0:6.1-20180804.1025 will be updated
Aug 6 05:18:57 server software-updates: log: ---> Package clearsdn-antimalware.noarch 0:6.1-20180805.1025 will be an update
Aug 6 05:18:57 server software-updates: log: ---> Package clearsdn-antispam.noarch 0:6.1-20180804.1025 will be updated
Aug 6 05:18:57 server software-updates: log: ---> Package clearsdn-antispam.noarch 0:6.1-20180805.1025 will be an update
Aug 6 05:18:57 server software-updates: log: --> Finished Dependency Resolution
Aug 6 05:18:57 server software-updates: log:
Aug 6 05:18:57 server software-updates: log: Dependencies Resolved
Aug 6 05:18:57 server software-updates: log:
Aug 6 05:18:57 server software-updates: log: ================================================================================
Aug 6 05:18:57 server software-updates: log: Package Arch Version Repository Size
Aug 6 05:18:57 server software-updates: log: ================================================================================
Aug 6 05:18:57 server software-updates: log: Updating:
Aug 6 05:18:57 server software-updates: log: clearsdn-antimalware
Aug 6 05:18:57 server software-updates: log: noarch 6.1-20180805.1025 private-clearcenter-antimalware 4.7 M
Aug 6 05:18:57 server software-updates: log: clearsdn-antispam
Aug 6 05:18:57 server software-updates: log: noarch 6.1-20180805.1025 private-clearcenter-antispam 2.0 M
Aug 6 05:18:57 server software-updates: log:
Aug 6 05:18:57 server software-updates: log: Transaction Summary
Aug 6 05:18:57 server software-updates: log: ================================================================================
Aug 6 05:18:57 server software-updates: log: Upgrade 2 Packages
Aug 6 05:18:57 server software-updates: log:
Aug 6 05:18:57 server software-updates: log: Total download size: 6.7 M
Aug 6 05:18:57 server software-updates: log: Downloading packages:
Aug 6 05:18:57 server software-updates: log: Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
Aug 6 05:18:57 server software-updates: log: --------------------------------------------------------------------------------
Aug 6 05:18:57 server software-updates: log: Total 3.1 MB/s | 6.7 MB 00:02
Aug 6 05:18:57 server software-updates: log: Running transaction check
Aug 6 05:18:57 server software-updates: log: Running transaction test
Aug 6 05:18:57 server software-updates: log: Transaction test succeeded
Aug 6 05:18:57 server software-updates: log: Running transaction
Aug 6 05:18:57 server software-updates: log: Updating : clearsdn-antispam-6.1-20180805.1025.noarch 1/4
Aug 6 05:18:57 server software-updates: log: Updating : clearsdn-antimalware-6.1-20180805.1025.noarch 2/4
Aug 6 05:18:57 server software-updates: log: Cleanup : clearsdn-antispam-6.1-20180804.1025.noarch 3/4
Aug 6 05:18:57 server software-updates: log: Cleanup : clearsdn-antimalware-6.1-20180804.1025.noarch 4/4
Aug 6 05:18:57 server software-updates: log: Verifying : clearsdn-antimalware-6.1-20180805.1025.noarch 1/4
Aug 6 05:18:57 server software-updates: log: Verifying : clearsdn-antispam-6.1-20180805.1025.noarch 2/4
Aug 6 05:18:57 server software-updates: log: Verifying : clearsdn-antispam-6.1-20180804.1025.noarch 3/4
Aug 6 05:18:57 server software-updates: log: Verifying : clearsdn-antimalware-6.1-20180804.1025.noarch 4/4
Aug 6 05:18:57 server software-updates: log:
Aug 6 05:18:57 server software-updates: log: Updated:
Aug 6 05:18:57 server software-updates: log: clearsdn-antimalware.noarch 0:6.1-20180805.1025
Aug 6 05:18:57 server software-updates: log: clearsdn-antispam.noarch 0:6.1-20180805.1025
Aug 6 05:18:57 server software-updates: log:
Aug 6 05:18:57 server software-updates: log: Complete!
Aug 6 05:18:57 server software-updates: log: ------------------- software update complete ---------------------
Aug 6 05:19:56 server events: software_updates - event occurred
Aug 6 05:19:56 server events: software_updates - triggered hook: base
Aug 6 05:19:56 server events: software_updates - triggered hook: central-management
Aug 6 06:20:04 server app-antispam-updates: Service requires an update.
Aug 6 06:20:30 server engine: exception: error: /usr/clearos/apps/base/libraries/Shell.php (227): Command execution failed.
Aug 6 06:20:30 server engine: exception: debug backtrace: /usr/clearos/apps/base/libraries/Yum.php (197): execute
Aug 6 06:20:30 server engine: exception: debug backtrace: /usr/clearos/apps/clearcenter/libraries/Application_Web_Service.php (178): install
Aug 6 06:20:30 server engine: exception: debug backtrace: /usr/sbin/clearcenter-update (79): install_update
Aug 6 06:26:04 server app-antimalware-updates: Service requires an update.
Aug 6 06:26:27 server engine: exception: error: /usr/clearos/apps/base/libraries/Shell.php (227): Command execution failed.
Aug 6 06:26:27 server engine: exception: debug backtrace: /usr/clearos/apps/base/libraries/Yum.php (197): execute
Aug 6 06:26:27 server engine: exception: debug backtrace: /usr/clearos/apps/clearcenter/libraries/Application_Web_Service.php (178): install
Aug 6 06:26:27 server engine: exception: debug backtrace: /usr/sbin/clearcenter-update (79): install_update

This sequence happens on a nightly basis
TagsNo tags attached.
Attached Files

- Relationships
related to 0015731confirmed Change signature update methodology - antimalware 

-  Notes
(0007871)
pbaldwin (administrator)
2018-08-14 12:41

The fix for 0021081 resolves the ugly backtrace in the system log. It's not fatal, but there's no need to pollute the system log.

The "antimalware update" (ClearSDN tool) does not know that "yum" (GPL, no SDN) came along and already did an update. The SDN tool does a sanity check at the end of the process, but it should also do a full version check at the start of the process. Yes, the current implementation can lead to an unnecessary "antimalware update", but it's harmless (and sometimes necessary). This will be tidied up in 0015731

- Issue History
Date Modified Username Field Change
2018-08-06 01:42 NickH New Issue
2018-08-10 11:47 pbaldwin Status new => confirmed
2018-08-10 11:47 pbaldwin Target Version => 7.5.0 Updates
2018-08-13 15:20 pbaldwin Summary Anti-malaware and Antispam updates wirking incorrectly => Anti-malware and Antispam updates wirking incorrectly
2018-08-14 12:24 pbaldwin Summary Anti-malware and Antispam updates wirking incorrectly => Anti-malware and Antispam updates working incorrectly
2018-08-14 12:24 pbaldwin Relationship added related to 0015731
2018-08-14 12:24 pbaldwin Status confirmed => resolved
2018-08-14 12:24 pbaldwin Fixed in Version => 7.5.0 Updates
2018-08-14 12:24 pbaldwin Resolution open => fixed
2018-08-14 12:24 pbaldwin Assigned To => pbaldwin
2018-08-14 12:41 pbaldwin Note Added: 0007871
2018-08-14 12:41 pbaldwin Status resolved => closed