ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0020981ClearOSapp-network - Network Settingspublic2018-08-02 07:342018-10-24 18:02
ReporterNickH 
Assigned Topbaldwin 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version7.5.0 UpdatesFixed in Version7.5.0 Updates 
Summary0020981: Odd behaviour of bridged interfaces in IP Settings
DescriptionSome bridged interface support has now been added however:

1 - If you want to create a bridged interface in the webconfig, there is no way to initially do so. You need to create ifcfg-br0 manually and then it will show up as a configurable element in the webconfig.
2 - If you then delete the interface in the webconfig, it deletes the ifcfg-br0 file but br0 interface stays in the webconfig with an Add action button. There appears to be no way to remove it from the webconfig.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007721)
pbaldwin (administrator)
2018-08-04 23:58

Sorry about that. The "bridged" branch - https://gitlab.com/clearos/clearfoundation/app-network/tree/bridged [^] - was merged with master due to some awkward workflows. I attempted to disable the bridge support, but did not consider command line hackers. I'll just finish up the feature instead of trying to unmerge the branch.

Aside: I recently completed some tools to help with developer workflows! We'll be able to build off of tags instead of a side branch (e.g. clear7). This is a more typical and pleasant workflow.

- Issue History
Date Modified Username Field Change
2018-08-02 07:34 NickH New Issue
2018-08-04 23:54 pbaldwin Assigned To => pbaldwin
2018-08-04 23:54 pbaldwin Status new => confirmed
2018-08-04 23:58 pbaldwin Note Added: 0007721
2018-08-05 00:06 pbaldwin Target Version => 7.5.0 Updates
2018-09-24 19:36 pbaldwin Status confirmed => resolved
2018-09-24 19:36 pbaldwin Fixed in Version => 7.5.0 Updates
2018-09-24 19:36 pbaldwin Resolution open => fixed
2018-10-24 18:02 pbaldwin Status resolved => closed