ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002098ClearOSapp-php - PHPpublic2015-01-02 12:362017-07-05 10:46
Reportermarclaporte 
Assigned Topbaldwin 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version6.6.0 Beta 2 
Target Version7.3.1 UpdatesFixed in Version7.3.1 Updates 
Summary0002098: PHP: Setting default_charset to an empty value is not recommended.
DescriptionPlease see:
http://php.net/manual/en/ini.core.php#ini.default-charset [^]

This is low priority because admins can do themselves by adding default_charset = "UTF-8" in /etc/php.ini

However, since "In PHP 5.6 onwards, UTF-8 is the default value", and since ClearOS users haven't yet started using PHP apps in a massive way (which will inevitably happen), I suggest to make the change sooner than later, and avoid any upgrade pain.

Thanks!
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005811)
pbaldwin (administrator)
2017-06-23 20:48

https://github.com/clearos/app-php/commit/3989ee786a008397f4ee4cec643c059935c18561 [^]

This will only trigger on new installs.

- Issue History
Date Modified Username Field Change
2015-01-02 12:36 marclaporte New Issue
2015-01-05 13:03 pbaldwin Status new => confirmed
2017-05-29 20:33 pbaldwin Target Version => 7.3.1 Updates
2017-06-23 20:48 pbaldwin Note Added: 0005811
2017-06-23 20:48 pbaldwin Status confirmed => resolved
2017-06-23 20:48 pbaldwin Fixed in Version => 7.3.1 Updates
2017-06-23 20:48 pbaldwin Resolution open => fixed
2017-06-23 20:48 pbaldwin Assigned To => pbaldwin
2017-07-05 10:46 pbaldwin Status resolved => closed