ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0018531ClearOSapp-network - Network Settingspublic2018-01-09 13:452018-10-24 18:02
ReporterNickH 
Assigned Topbaldwin 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.4.0 
Target VersionFixed in Version7.5.0 Updates 
Summary0018531: Webconfig objects to PPPoE with 255.255.255.255 netmask in standalone mode
DescriptionWhen ClearOS is in standalone mode with an external PPPoE interface, if its netmask is 255.255.255.255, the Webconfig Web Server app or Flexshare app gives an "Ooooops!Net mask is invalid.". If put into gateway mode the error disappears. It appears this bug was introduced in 7.4. I do not have PPPoE so I can't check it out, but please see the following forum thread: https://www.clearos.com/clearfoundation/social/community/system-update-to-7-4-show-ooooops-net-mask-is-invailid. [^]
TagsNo tags attached.
Attached Files

- Relationships
related to 0021571closedpbaldwin Filter out network interfaces with 255.255.255.255 netmask 

-  Notes
(0006891)
pbaldwin (administrator)
2018-01-09 14:15

I'm not convinced this is a bug. I was hoping to get the ifconfig output to verify that the interface was indeed a PPPoE/PPP interface and not a regular (e.g. eth0) interface. I have a feeling it's the latter.
(0006901)
NickH (developer)
2018-01-10 01:04

Feedback posted to the forum:
https://www.clearos.com/clearfoundation/social/community/system-update-to-7-4-show-ooooops-net-mask-is-invailid#reply-203141 [^]
(0006911)
pbaldwin (administrator)
2018-01-10 02:14

Confirmed - thanks! Added to the bug queue.
(0008001)
pbaldwin (administrator)
2018-09-24 20:11

Since the API is allowing 255.255.255.255 netmasks, it's now up to external apps to handle this scenario. For example, when Flexshare enumerates all the LANs on the network for "LAN Access", the underlying engine (Apache) won't like seeing 255.255.255.255 for non point-to-point interfaces.

- Issue History
Date Modified Username Field Change
2018-01-09 13:45 NickH New Issue
2018-01-09 14:15 pbaldwin Note Added: 0006891
2018-01-09 14:15 pbaldwin Status new => feedback
2018-01-10 01:04 NickH Note Added: 0006901
2018-01-10 01:04 NickH Status feedback => new
2018-01-10 02:14 pbaldwin Note Added: 0006911
2018-01-10 02:14 pbaldwin Status new => confirmed
2018-01-10 02:14 pbaldwin Target Version => 7.4.0 Updates
2018-02-12 10:19 pbaldwin Target Version 7.4.0 Updates =>
2018-09-24 19:44 pbaldwin Issue cloned: 0021571
2018-09-24 19:44 pbaldwin Relationship added related to 0021571
2018-09-24 20:11 pbaldwin Note Added: 0008001
2018-09-24 20:11 pbaldwin Status confirmed => resolved
2018-09-24 20:11 pbaldwin Fixed in Version => 7.5.0 Updates
2018-09-24 20:11 pbaldwin Resolution open => fixed
2018-09-24 20:11 pbaldwin Assigned To => pbaldwin
2018-10-24 18:02 pbaldwin Status resolved => closed