ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0013741ClearOSapp-reports-database - Reports Databasepublic2017-03-14 08:482017-03-14 11:58
Reporterpbaldwin 
Assigned Topbaldwin 
PriorityhighSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.3.0 
Target Version7.3.1 UpdatesFixed in Version 
Summary0013741: MariaDB CURRENT_TIMESTAMP no longer works
DescriptionThe timestamp field for the network report is defined in the table creation:

CREATE TABLE `network` (
  ....
  `timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP,
   ...

The CURRENT_TIMESTAMP is now set to "0000-00-00 00:00:00" instead of the current time. It looks like this has been an ongoing issue according to this bug report -- https://jira.mariadb.org/browse/MDEV-6880?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel [^]

Note:
- "Resource Report" suffers from the same problem
- "Proxy Report" is unaffected. Though it does use CURRENT_TIMESTAMP, the timestamps are set explicitly based on log file timestamps.

   
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0013721closedbchambers New purge script drop tables' options 

-  Notes
(0005151)
bchambers (administrator)
2017-03-14 08:50

Is this not a duplicate/resolved issue of https://tracker.clearos.com/view.php?id=13721 [^]

- Issue History
Date Modified Username Field Change
2017-03-14 08:48 pbaldwin New Issue
2017-03-14 08:48 pbaldwin Priority normal => high
2017-03-14 08:48 pbaldwin Assigned To => pbaldwin
2017-03-14 08:48 pbaldwin Status new => confirmed
2017-03-14 08:50 bchambers Note Added: 0005151
2017-03-14 09:04 pbaldwin Relationship added duplicate of 0013721
2017-03-14 09:04 pbaldwin Status confirmed => resolved
2017-03-14 09:04 pbaldwin Resolution open => fixed
2017-03-14 11:58 pbaldwin Status resolved => closed