ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011271ClearOSwebconfig-httpdpublic2016-11-27 19:572017-08-13 13:06
Reporterbchambers 
Assigned Topbaldwin 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.2.0 
Target Version7.4.0 Beta 1Fixed in Version7.4.0 Beta 1 
Summary0011271: Webconfig restart noise with VLAN
DescriptionIf you create VLAN's or virtual interfaces, you could end up with configuration that looks something like this:

# ISP Maximum Speeds
ENP0S3.1_MAX_DOWNSTREAM=0
ENP0S3.1_MAX_UPSTREAM=0
ENP0S3.1234_MAX_DOWNSTREAM=0
ENP0S3.1234_MAX_UPSTREAM=0
ENP0S8_MAX_DOWNSTREAM=1110
ENP0S8_MAX_UPSTREAM=1110
ENP0S3_MAX_DOWNSTREAM=6400
ENP0S3_MAX_UPSTREAM=930

Webconfig's /usr/libexec/webconfig/prestart.sh tries to source the clearos network.conf file and will throw some ugly (but not fatal) warnings:

bash: ENP0S3.1_MAX_DOWNSTREAM=0: command not found
bash: ENP0S3.1_MAX_UPSTREAM=0: command not found
bash: ENP0S3.1234_MAX_DOWNSTREAM=0: command not found
bash: ENP0S3.1234_MAX_UPSTREAM=0: command not found

Should naming convention be changed to underscore instead of dots? Perhaps too big a change for annoyance issue.

Could source ignore some of these lines in network.conf?

Log as 'annoyance'...just something to think about.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004221)
pbaldwin (administrator)
2016-12-05 20:42

The period in the VLAN interface name is a standard convention, so the API will need to handle that scenario.

Note: I was unable to duplicate the configuration -- the GUI does not show speed test / bandwidth settings for VLAN and Virtual interfaces.
(0004231)
bchambers (administrator)
2016-12-06 07:26

Hmm...this was discovered on my development box, so I'm betting those entries got added during development of the bw speed test feature before it was impossible to configure speed on a VLAN or virtual interface.

I think we can close as "not a bug".
(0006231)
pbaldwin (administrator)
2017-08-12 06:39

Simple fix - https://github.com/clearos/webconfig-httpd/commit/d5f4eadaa60c5e85b4f7cc3bb50a339a119d8174 [^]

- Issue History
Date Modified Username Field Change
2016-11-27 19:57 bchambers New Issue
2016-12-05 20:42 pbaldwin Note Added: 0004221
2016-12-05 20:42 pbaldwin Status new => acknowledged
2016-12-06 07:26 bchambers Note Added: 0004231
2017-08-12 06:38 pbaldwin Target Version => 7.4.0 Beta 1
2017-08-12 06:39 pbaldwin Note Added: 0006231
2017-08-12 06:39 pbaldwin Status acknowledged => resolved
2017-08-12 06:39 pbaldwin Fixed in Version => 7.4.0 Beta 1
2017-08-12 06:39 pbaldwin Resolution open => fixed
2017-08-12 06:39 pbaldwin Assigned To => pbaldwin
2017-08-13 13:06 pbaldwin Status resolved => closed