ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011191ClearOSapp-content-filter - Content Filterpublic2016-11-08 11:532016-12-16 14:04
Reporterbchambers 
Assigned Topbaldwin 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.2.0 
Target Version7.3.0 Beta 1Fixed in Version7.3.0 Beta 1 
Summary0011191: DG not restarting on config change
DescriptionDid something change?

filewatch-content-filter-configuration.conf

uses 'reload' action:

<action>sudo /sbin/service dansguardian-av reload</action>

But reload for DG isn't supported:

# sudo /sbin/service dansguardian-av reload
Redirecting to /bin/systemctl reload dansguardian-av.service
Failed to reload dansguardian-av.service: Job type reload is not applicable for unit dansguardian-av.service.

Should this be restart?

# sudo /sbin/service dansguardian-av restart
Redirecting to /bin/systemctl restart dansguardian-av.service


TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004111)
pbaldwin (administrator)
2016-11-08 14:51

The Content Filter UI should be handling all the post-configuration restarts and it looks like that the case most (in not all) of the time, e.g. "grep reset controllers/*php"

banned_ips.php: $this->dansguardian->reset(TRUE);
banned_ips.php: $this->dansguardian->reset(TRUE);
blacklists.php: $this->dansguardian->reset(TRUE);
exception_ips.php: $this->dansguardian->reset(TRUE);
exception_ips.php: $this->dansguardian->reset(TRUE);
exception_sites.php: $this->dansguardian->reset(TRUE);
exception_sites.php: $this->dansguardian->reset(TRUE);
file_extensions.php: $this->dansguardian->reset(TRUE);
general.php: $this->dansguardian->reset(TRUE);
gray_sites.php: $this->dansguardian->reset(TRUE);
gray_sites.php: $this->dansguardian->reset(TRUE);
mime_types.php: $this->dansguardian->reset(TRUE);
phrase_lists.php: $this->dansguardian->reset(TRUE);
policy.php: $this->dansguardian->reset(TRUE);
policy.php: $this->dansguardian->reset(TRUE);
policy.php: $this->dansguardian->reset(TRUE);
settings.php: $this->dansguardian->reset(TRUE);


The clearsync configlet file should be removed after doing a review to make sure all config changes via webconfig trigger a restart.

- Issue History
Date Modified Username Field Change
2016-11-08 11:53 bchambers New Issue
2016-11-08 14:51 pbaldwin Note Added: 0004111
2016-11-08 14:51 pbaldwin Status new => confirmed
2016-11-30 10:35 pbaldwin Target Version => 7.3.0 Beta 1
2016-12-09 08:34 pbaldwin Status confirmed => resolved
2016-12-09 08:34 pbaldwin Fixed in Version => 7.3.0 Beta 1
2016-12-09 08:34 pbaldwin Resolution open => fixed
2016-12-09 08:34 pbaldwin Assigned To => pbaldwin
2016-12-16 14:04 pbaldwin Status resolved => closed