ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0015481ClearOSapp-netify-fwa - Netify Firewall Agentpublic2017-06-27 11:352017-07-11 10:26
ReporterNickH 
Assigned Todsokoloski 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.3.0 
Target Version7.3.1 UpdatesFixed in Version7.3.1 Updates 
Summary0015481: /etc/clearos/firewall.d/10-netify-fwa loads firewall rules multiiple times
DescriptionPlease see forum thread https://www.clearos.com/clearfoundation/social/community/problem-with-firewall-and-multiwan#reply-180221 [^]

On a firewall restart /etc/clearos/firewall.d/10-netify-fwa loads its firewall rules many times over. I am suspecting a corrupt /etc/netify-fwa.conf or /usr/clearos/apps/netify_fwa/deploy/netify-fwa.sed but I am waiting to see the files.

There is a further issue in the thread which may need its own bug where the firewall panics after the poster tried changing multiwan configurations. The error message is:
firewall: Error: /usr/clearos/apps/firewall/deploy/firewall.lua:2232: bad argument 0000001 to 'pairs' (table expected, got nil)
firewall: Running firewall panic mode...
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2017-06-27 11:35 NickH New Issue
2017-06-28 07:20 bchambers Assigned To => dsokoloski
2017-06-28 07:20 bchambers Status new => assigned
2017-06-29 11:32 dsokoloski Status assigned => resolved
2017-06-29 11:32 dsokoloski Resolution open => fixed
2017-07-06 14:24 pbaldwin Category app-application-filter - Application Filter => app-netify-fwa - Netify Firewall Agent
2017-07-06 14:26 pbaldwin Fixed in Version => 7.3.1 Updates
2017-07-06 14:26 pbaldwin Target Version => 7.3.1 Updates
2017-07-11 10:26 pbaldwin Status resolved => closed