ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0014161ClearOSphpMyAdminpublic2017-04-03 09:132017-08-07 09:25
Reporterpbaldwin 
Assigned Topbaldwin 
PrioritynormalSeveritytweakReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.3.1 
Target Version7.3.1 UpdatesFixed in Version7.3.1 Updates 
Summary0014161: Auto-fix configuration file permissions
DescriptionThe phpMyAdmin configuration file (/etc/phpMyAdmin/config.inc.php) needs to be readable by the web server. In the ClearOS package, the "webconfig" group is granted permissions. In the EPEL and RemiRepo versions, the "apache" group is granted permissions.

Switching back and forth between these versions is problematic due to the way configuration files are managed in the RPM package manager. On an upgrade, the permissions on an existing configuration file are preserved.

Short term solution: make sure the ClearOS phpMyAdmin package fixes permissions on install.

Long term solution: maintain phpMyAdmin 4.7.x.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2017-04-03 09:13 pbaldwin New Issue
2017-04-03 09:32 pbaldwin Status new => confirmed
2017-08-06 21:08 pbaldwin Status confirmed => resolved
2017-08-06 21:08 pbaldwin Fixed in Version => 7.3.1 Updates
2017-08-06 21:08 pbaldwin Resolution open => fixed
2017-08-06 21:08 pbaldwin Assigned To => pbaldwin
2017-08-07 09:25 pbaldwin Status resolved => closed