ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010581ClearOSapp-events - Events Systempublic2016-09-15 09:482016-11-30 10:28
Reporterpbaldwin 
Assigned Topbaldwin 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version7.2.0 
Target Version7.3.0 Beta 1Fixed in Version7.3.0 Beta 1 
Summary0010581: Create an "onboot" event
DescriptionIn ClearOS, we need to bind to specific interfaces (e.g. Squid, CUPS) more than a typical Linux distribution. Many upstream systemd scripts contain this directive:

[Unit]
...
After=network.target

The problem: there's no guarantee that the network has bind-able interfaces when the "network.target" event occurs. Since we don't want to patch a bunch of upstream systemd scripts, create an "onboot" event as a workaround. Any app that needs to bind to specific IPs should have a sanity check script added to /var/clearos/events/onboot.

See app-print-server for an example.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2016-09-15 09:48 pbaldwin New Issue
2016-09-15 09:48 pbaldwin Status new => resolved
2016-09-15 09:48 pbaldwin Fixed in Version => 7.3.0 Beta 1
2016-09-15 09:48 pbaldwin Resolution open => fixed
2016-09-15 09:48 pbaldwin Assigned To => pbaldwin
2016-11-16 09:12 pbaldwin Target Version 7.3.0 Beta 1 => 7.3.0 Beta 1
2016-11-16 09:12 pbaldwin Fixed in Version 7.3.0 Beta 1 => 7.3.0 Beta 1
2016-11-30 10:28 pbaldwin Status resolved => closed