ClearOS Bug Tracker


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001885ClearOSapp-network-detail-report - Network Detail Reportpublic2014-08-06 12:112019-03-19 10:33
ReporterNickH 
Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version6.5.0 
Target VersionFixed in Version 
Summary0001885: app-network-detail-report causes runaway system-mysqld process
DescriptionSince the update of app-network-detail-report to 1.5.27 my system-mysqld process has run away causing a 100% CPU load. It is very similar to this thread: http://www.clearfoundation.com/component/option,com_kunena/Itemid,232/catid,12/func,view/id,61448/limit,10/limitstart,10/. [^]
Removing app-network-detail-report and app-network-detail-report-core on their own did not fix it. I also had to remove pmacct.
Additional InformationI have not tried the suggestion by zombu2 in the thread as I don't know how to reverse it if it goes wrong and I'd prefer an official ClearOS solution.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001264)
user2
2014-08-06 15:23

Will verify in the a.m.
(0001266)
dloper (administrator)
2014-08-07 09:00

Here is another related report:

"CPU trashing of system-mysqld seems related to /usr/sbin/networkdetail2db.
I have disabled this cron job for the mean time.

"There seems to be a stale lock on the process, as /var/log/syslog has many
instances of
"networkdetail2db: Unable to start script - currently running."
"I don't see where the lock is being stored.

I"nside the reports DB, the network_detail schema is missing indexes on at
least the following rows. I don't recall if I ever posted a bug report on
the rpm install for app-network-detail-*. Basically, IIRC, the post-install
script parses for the existance of a network* table from reports. However,
how it is written, the initialization of the database fails because the way
the regex is written, it's far too aggressive and finds app-network-*
first, then skips the db init."
(0001304)
intelliant (reporter)
2014-10-31 00:24
edited on: 2014-10-31 00:24

I did try what zombu2 has stated herein - http://www.clearfoundation.com/component/option,com_kunena/Itemid,232/catid,12/func,view/id,61448/limit,10/limitstart,10/#61936 [^] but to no avail. The problem remains.

Have just uninstalled network detailed report and will be observing over the next 24 hours.

(0001305)
intelliant (reporter)
2014-10-31 07:45

As reported by NickH, removal of pmacct is also required to get back to normal load.

- Issue History
Date Modified Username Field Change
2014-08-06 12:11 NickH New Issue
2014-08-06 15:23 user2 Note Added: 0001264
2014-08-06 15:23 user2 Status new => feedback
2014-08-07 09:00 dloper Note Added: 0001266
2014-10-31 00:24 intelliant Note Added: 0001304
2014-10-31 00:24 intelliant Note Edited: 0001304 View Revisions
2014-10-31 07:45 intelliant Note Added: 0001305
2019-03-19 10:33 NickH Summary app-network-detaill-report causes runaway system-mysqld process => app-network-detail-report causes runaway system-mysqld process